PT. Hawk Teknologi Solusi

Silahkan Cari Disini

Senin, 10 Agustus 2009

Blacklists/Blocklists

Blacklists or blocklists are lists of IP addresses, domain names, email addresses or content of the headers or the body, or some combination of these different types, that can be used to help identify spam. A special subset of IP address and domain name lists exist which can be queried using DNS, which are called DNS Blackhole Lists or DNSBLs. Blacklists can be unverified and cause “collateral damage”; their criteria for listing may not be clear.

Those blacklists listed here are just a tiny subset of all of the private access lists and ACLs that exist to block spam from private networks; that larger set is the source of the death of a thousand cuts that any spam friendly provider should eventually experience. They may not have the clout of SPEWS, but they may last even longer.


From:
http://spamlinks.net/filter-bl.htm


Postfix blacklist or reject an email address

Q. I’ve Postfix based CentOS Linux server. I need to blacklist email ID: user@abadboy.com . How do I blacklist email address with postfix? I also have spamassassin software installed.

A. By default, the Postfix SMTP server accepts any sender address. However you can block / blacklist sender email address easily with Postfix. It has SMTP server access table.

Open /etc/postfix/sender_access file
# cd /etc/postfix
# vi sender_access

Append sender email id as follows:
user@abadboy.com REJECT
Save and close the file. Use postmap command to create a database:
# postmap hash:sender_access
Now open main.cf and add code as follows:
smtpd_recipient_restrictions = check_sender_access hash:/etc/postfix/sender_access
Save and close the file. Restart / reload postfix MTA:
# /etc/init.d/postfix restart

You can also use spamassassin to blacklist email address. Just add to your own spamassassin configuration or to /etc/mail/spamassassin/local.cf file:
# vi /etc/mail/spamassassin/local.cf
Append blacklist as follows:
blacklist_from user@abadboy.com
Save and close the file. Restart spamassassin:
# /etc/init.d/spamassassin restart

spamassassin will marke mail as SPAM instead of rejecting the same.

From:
http://www.cyberciti.biz/faq/howto-blacklist-reject-sender-email-address/

Minggu, 09 Agustus 2009

Lindungi jaringan anda dari daftar ip yang terindentifikasi pada dshield dan spamhaus

Pagi ini lagi-lagi smtp ku di buat mabok oleh traffic spam , iseng aku cari di google bagaimana fetch daftar ip sumber spam langsung di mikrotik ternyata ketemu link berikut:

http://forum.mikrotik.com/viewtopic.php?f=9&t=24427


berikut adalah contoh script + scheduling + firewall filter yang saya gunakan di router mikrotik 3.25:


# aug/09/2009 11:27:24 by RouterOS 3.25
#
/system script
add name=fetch-dshield-spamhaus policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="## Parse D\
SHIELD & Spamhaus feed and build an address-list.\r\
\n## Written by Sam Norris, ChangeIP.com 2008\r\
\n## Any comments or suggestions welcome in the forums.\r\
\n##\r\
\n## 06/03/08 - Initial list parsing.\r\
\n\r\
\n/tool fetch address=feeds.dshield.org host=feeds.dshield.org mode=http s\
rc-path=block.txt\r\
\n/tool fetch address=www.spamhaus.org host=www.spamhaus.org mode=http src\
-path=drop/drop.lasso\r\
\n\r\
\n##\r\
\n## DSHIELD Drop List\r\
\n##\r\
\n\r\
\n:if ( [/file get [/file find name=block.txt] size] > 0 ) do={\r\
\n\r\
\n /ip firewall address-list remove [/ip firewall address-list find list=\
dshield]\r\
\n\r\
\n :global content [/file get [/file find name=block.txt] contents] ;\r\
\n :global contentLen [ :len \$content ] ;\r\
\n\r\
\n :global lineEnd 0;\r\
\n :global line \"\";\r\
\n :global lastEnd 0;\r\
\n\r\
\n :do {\r\
\n :set lineEnd [:find \$content \"\\n\" \$lastEnd ] ;\r\
\n :set line [:pick \$content \$lastEnd \$lineEnd] ;\r\
\n :set lastEnd ( \$lineEnd + 1 ) ;\r\
\n\r\
\n :if ( [:pick \$line 0 1] != \"#\" ) do={\r\
\n\r\
\n :if ([:typeof [:toip [:pick \$line 0 [:find \$line \"\\t\"] ] ] ] !=\
\_\"nil\") do={\r\
\n :local pos1 [:find \$line \"\\t\" 0]\r\
\n :local pos2 [:find \$line \"\\t\" \$pos1]\r\
\n :local pos3 [:find \$line \"\\t\" \$pos2]\r\
\n :log info ( \"DShield Entry: \" . [:pick \$line 0 \$pos1 ] . \"/\"\
\_. [:pick \$line (\$pos2+1) \$pos3 ] )\r\
\n /ip firewall address-list add list=dshield address=( [:pick \$line\
\_0 \$pos1 ] . \"/\" . [:pick \$line (\$pos2+1) \$pos3 ] )\r\
\n } \r\
\n\r\
\n }\r\
\n\r\
\n } while (\$lineEnd < \$contentLen)\r\
\n\r\
\n}\r\
\n\r\
\n##\r\
\n## SPAMHAUS.ORG Drop List\r\
\n##\r\
\n\r\
\n:if ( [/file get [/file find name=drop.lasso] size] > 0 ) do={\r\
\n\r\
\n /ip firewall address-list remove [/ip firewall address-list find list=\
spamhaus.lasso]\r\
\n\r\
\n :global content [/file get [/file find name=drop.lasso] contents] ;\r\
\n :global contentLen [ :len \$content ] ;\r\
\n\r\
\n :global lineEnd 0;\r\
\n :global line \"\";\r\
\n :global lastEnd 0;\r\
\n\r\
\n :do {\r\
\n :set lineEnd [:find \$content \"\\n\" \$lastEnd ] ;\r\
\n :set line [:pick \$content \$lastEnd \$lineEnd] ;\r\
\n :set lastEnd ( \$lineEnd + 1 ) ;\r\
\n\r\
\n :if ( [:pick \$line 0 1] != \";\" ) do={\r\
\n\r\
\n :if ([:len [:pick \$line 0 [:find \$line \";\"] ] ] > 0 ) do={\r\
\n :local pos1 [:find \$line \";\" 0]\r\
\n :local entry [:pick \$line 0 (\$pos1-1) ]\r\
\n :if ( [:len \$entry ] > 0 ) do={\r\
\n :log info \"Lasso Entry: \$entry\"\r\
\n /ip firewall address-list add list=spamhaus.lasso address=\$ent\
ry\r\
\n }\r\
\n } \r\
\n\r\
\n }\r\
\n\r\
\n } while (\$lineEnd < \$contentLen)\r\
\n\r\
\n}"
# aug/09/2009 11:27:47 by RouterOS 3.25
#
/system scheduler
add comment="" disabled=no interval=12h name=fecth-dshield-spamhaus on-event=\
fetch-dshield-spamhaus start-date=jan/01/1970 start-time=06:00:00
# aug/09/2009 11:33:37 by RouterOS 3.25
#
/ip firewall filter
add action=drop chain=forward comment="### DROP Spamhaus-Lasso" disabled=no \
src-address-list=spamhaus.lasso
add action=drop chain=forward comment="### DROP Dshield" \
disabled=no src-address-list=dshield
#

Jumat, 31 Juli 2009

ISP dan Keamanan Jaringan Internet

Saat ini Internet sudah mulai menjadi gaya hidup yang tanpa disadari diperlukan oleh hampir seluruh lapisan masyarakat seiring dengan kemajuan teknologi baik hardware maupun software.
Dengan fenomena layanan Facebook, Blog, Email dan Instant Messaging yang dapat diakses melalui berbagai macam gadget maka layanan Internet bukan lagi monopoli orang yang mampu menggunakan komputer dengan 101 tombol saja tetapi hampir semua lapisan masyarakat dapat mengakses layanan Internet dengan sangat mudah.

Internet Service Provider yang merupakan gerbang bagi para pengguna Internet saat ini menghadapi tantangan untuk dapat tetap memberikan layanan Internet yang berkualitas, terjangkau dan aman bagi penggunanya.

Bicara tentang keamanan Internet tidak terlepas dari Sistem Keamanan Jaringan Komputer yang sangat komplek dan banyak lapisan walaupun dapat di rangkum dalam tiga hal besar saja yaitu:

Confidentiality (kerahasiaan data)
Integrity (Integritas / keutuhan / keaslian, termasuk pengaturan hak akses)
Availability (Ketersediaan layanan)

selain itu bicara tentang keamanan jaringan komputer mau tidak mau tunduk terhadap model segitiga yang memiliki tiga sisi:

sisi kemanan
sisi kenyamanan/kemudahan
sisi fungsi

dimana ketiga sisi tersebut saling bertolak belakang, artinya mengutamakan salah satu berarti mengurangi yang lainnya dengan demikian yang dapat dicapai adalah mencari komposisi yang paling dapat diterima oleh pengguna, dengan demikian menurut saya visi keamanan di ISP adalah:

Menciptakan Internet yang aman, nyaman dan berfungsi dengan baik

visi diatas sangat sederhana tetapi untuk mencapi hal tersebut terus terang tidak mudah dan butuh banyak pemikiran pertimbangan dan pemahaman dari semua stake holder sbb:

1. Pengguna Internet
2. Internet Service Provider (ISP) termasuk Network Access Provider
3. Content Provider termasuk penyelenggara e-Bussines/e-Commerce dan infrastruktur pendukungnya yaitu: Bank, penerbit Certified Authorization (CA) dan logistik.
4. Penyelenggara Jaringan
5. Pemerintah

tentunya tidak semua aspek dapat diakomodir oleh ISP, karena sejatinya ISP minimal memiliki layanan standar sbb:

1. DNS server / nameserver sebagai sarana resolve domain ke IP atau sebaliknya
2. Email server sebagai outgoing dan atau incoming server
3. Proxy server sebagai perantara akses web sekaligus sebagai cache dan filtering konten pada lapisan aplikasi
4. Webhosting sebagai sarana untuk mempublikasikan halaman web
5. RADIUS Server sebagai Authentication Authorization Accounting (AAA) untuk Billing Server
6. Routing Alamat IP agar user/pengguna dapat mengkakses layanan-layanan tersebut melalui protocol TCP/IP yang dihubungkan satu dengan lainnya secara terbuka atau dengan kata lain jaringan Publik (Internet)
7. Sistem Monitoring dan manajemen Jaringan

Dengan demikian bagian keamanan yang harus di akomodir oleh ISP setidaknya adalah:
1. Menyediakan Nameserver yang handal dan aman yang bebas dari dns poisoning / spoofing
2. Menyediakan Email server yang mampu menyaring email sampah (Spam), virus dan mallware lainnya
3. Menyediakan Proxy Server yang mampu menyaring pishing dan membatasi konten-konten mallware lainnya.
4. Menyediakan Webhosting yang aman yang tidak menyimpan kode-kode jahat seperti pishing, virus, trojan, mallware dan konten-konten yang mengandung unsur SARA (Suku Agama Ras)
5. Menyediakan RADIUS Server yang handal, aman dan tidak merugikan pelanggan baik secara finansial maupun secara kerahasiaan username password pelanggan tersebut.
6. Menyediakan sistem routing paket TCP/IP yang handal, aman dan terbebas dari serangan: Spoofing, Distributed Denial of Service, Worm dll.
7. Memiliki sistem monitoring dan manajemen jaringan untuk dapat menganalisa dan mengatasi permasalahan jika terjadi hal-hal yang disebut diatas.

adapun layanan-layanan lainnya selain tujuh hal yang disebutkan diatas lebih sebagai tanggung jawab pengelola konten baik itu bagi ISP yang memiliki konten, maupun institusi yang menyediakan konten bagi pengguna Internet termasuk: E-Banking/Bank, Pengelola E-Business/E-Commerce, E-Learning/Kampus, E-Goverment/Pemerintah, Pengelola Portal dll.

Sedangkan untuk Warnet sejatinya adalah mini ISP yang menyediakan/menyewakan sarana bagi pengguna Internet yang tidak mengakses Internet dari perangkat pribadinya.

Dalam hal terjadinya cybercrime ISP berperan untuk membantu perangkat hukum melakukan investigasi dan mencari bukti-bukti digital yang sekiranya dapat menjadi petunjuk dan bukti di pengadilan sesuai dengan perundang-undangan yang berlaku.

Bentuk barang bukti dan petunjuk bisa berupa analisa header email, logfile aplikasi server-server yang telah disebutkan diatas dan analisa traffic.

Khusus untuk analisa traffic tidaklah bijaksana untuk menganalisa semua taffic data secara paket pada lapisan 3 dan 4 (network layer dan transport layer) secara terus menerus karena akan mengganggu fungsi dan kenyamanan dari layanan Internet itu sendiri, adapun yang dapat dilakukan adalah analisa paket secara langsung pada saat insident keamanan terjadi atau biasa disebut sniffing. analoginya adalah jika tiap hari semua kendaraan di jalan raya diperiksa stnk dan kesesuaiannya dengan nomor mesin dan nomor rangka dan sim pengendaranya maka yang ada adalah kemacetan di sepanjang jalan sehingga kenyamanan dan fungsi dari kendaraan itu menjadi tidak ada artinya lagi, yang lumrah terjadi adalah pada saat terjadi laporan kehilangan mobil atau kasus penculikan atau kasus-kasus pidana lainnya termasuk kasus teroris yang terjadi belum lama ini terjadi maka jajaran kepolisian melakukan razia di titik rawan terhadap kendaraan bermotor tersebut bukan?

Kesimpulan:
Untuk menciptakan layanan Internet yang aman, nyaman dan berfungsi sebagaimana mestinya diperlukan kerja sama semua pihak dan pemahaman yang benar terhadap aspek-aspek keamanan jaringan Internet tersebut baik secara teknis maupun non-teknis.

masukan/saran dan pendapat dari berbagai pihak sangat diperlukan untuk mencapai visi tersebut.

Wasalam
Harijanto Pribadi
Kabid. Internet Security APJII periode 2009 - 2012

Senin, 15 Juni 2009

Jailbreak and/or unlock your iPhone 2G with version 2.2.1

fuih , setelah baca sana baca sini akhirnya aku bisa men Jailbreak/Unlock iphone 2g ku dengan versi 2.2.1

caranya aku baca di : http://www.iphonedownloadblog.com/2008/11/23/unlock-your-iphone-2g-22-using-quickpwn/

langkah-langkahnya kurang lebih sbb:

download file-file berikut:

1. http://appldnld.apple.com.edgesuite.net/content.info.apple.com/iPhone/061-5830.20090127.Mmni6/iPhone1,1_2.2.1_5H11_Restore.ipsw
2. http://torrents.thepiratebay.org/4689995/QuickPwn-225-2.zip.4689995.TPB.torrent
3. http://iphonefreakz.com/firmware/BL-39.bin
4. http://iphonefreakz.com/firmware/BL-46.bin

langkah-langkahnya

1. aktifkan itunes8 dan pasang kabel data+usb pc ke iphone
2. jika iphone sudah terdeteksi di itunes8 maka akan muncul disamping kanan pada bagian devices, lalu klik devices tsb maka akan muncul pada tab summary tombol restore.
3. tekan tombol shift + klik tombol restore maka kita dapat memilih firmware / file ipsw yang telah kita download (no.1) dan lakukan proses restore.
4. tunggu sampai proses restore selesai, setelah selesai (ditandai dengan iphone yang mereboot dirinya sendiri) tutup aplikasi itunes8 tsb dan jangan lakukan apapun pada iphone.
5. Jalankan QuickPwn.exe yang telah kita download (no.2) , oh ya downloadnya pake bittorrent ya.
6. Biarkan sampai tombol biru pada QuickPwn aktif artinya iphone telah terdeteksi lalu klik tombol tsb.
7. langkah selanjutnya adalah browse file ipsw / firmware yang sama yang tadi kita restore via itunes8 diatas (point no.3) lalu klik tombol biru lagi, jika firmware cocok akan ada tanda centrang hijau, ok klik lagi tombol biru.
8. selanjutnya diminta untuk browse file no.3 dan no.4 yang merupakan bootloader yang dibutuhkan lalu klik tombol biru lagi.
9. setelah itu biasanya ada konfirmasi untuk memastikan bahwa kabel data usb terpasang antara pc dan iphone, nah disini triknya pada saat keluar konfirmasi layar tsb coba untuk cabut dan pasang lagi kabel usb tsb di pc agar pc dipaksa mengidentifikasi device iphone tsb, kalau sudah terdengar bunyi ding-ding artinya usb terdektsi maka klik tombol biru
10. selanjutnya iphone akan masuk dalam mode recovery jangan alihkan perhatian anda dari layar monitor dan ikuti perintah berikut:
You will be asked to hold down the Power button for 5 seconds. Then you will have to also hold down the Home button for 10 seconds without letting go of the Power button. At the end of 10 seconds you will need to release only the Power button.

ok jika anda dengan benar mengikuti perintah diatas maka iphone akan masuk dalam proses Jailbrake / Unlock

dan trala..... akhirnya iphone 2g ku sudah siap digunakan dengan firmware 2.2.1 jadi bisa install facebook application dan yahoo messenger di iphone sayang masih 2g tapi mayanlah :)




Rabu, 22 April 2009

Aktifkan bpdu-filter di switch Procurve

Sore ini lagi-lagi ada masalah dengan link DS3 ku :(
anehnya setelah link normal dan kabel DS3 dikembalikan paket tetap tidak mau mengalir padahal di test pake notebook udah jalan....

Ternyata masalahnya di HP Procurve bpdu-filter belum aku aktifkan
apa itu BPDU bisa dibaca di
http://en.wikipedia.org/wiki/Spanning_tree_protocol#Bridge_Protocol_Data_Units_.28BPDUs.29

sedangkan cara mengaktifkan bpdu-filter di HP Procurve bisa dibaca di:

http://evilrouters.net/2009/03/11/bpdu-protection-on-hp-procurve-switches/

semoga bermanfaat

Kamis, 26 Maret 2009

No more "overrun: No buffer space available"

Setelah berhari-hari mencari akhirnya ketemu juga jawabannya agar quagga di fedora 9 tidak muncul error "netlink-listen: overrun: No buffer space available"

ternyata di fedora 9 configurasinya ada di /etc/sysconfig/quagga yang isinya:

#
# Default: Bind all daemon vtys to the loopback(s) only
#
QCONFDIR="/etc/quagga"
BGPD_OPTS="-A 127.0.0.1 -f ${QCONFDIR}/bgpd.conf"
OSPF6D_OPTS="-A ::1 -f ${QCONFDIR}/ospf6d.conf"
OSPFD_OPTS="-A 127.0.0.1 -f ${QCONFDIR}/ospfd.conf"
RIPD_OPTS="-A 127.0.0.1 -f ${QCONFDIR}/ripd.conf"
RIPNGD_OPTS="-A ::1 -f ${QCONFDIR}/ripngd.conf"
#ZEBRA_OPTS="-A 127.0.0.1 -f ${QCONFDIR}/zebra.conf"
ZEBRA_OPTS="-A 127.0.0.1 --nl-bufsize 200000 -f ${QCONFDIR}/zebra.conf"

ISISD_OPTS="-A ::1 -f ${QCONFDIR}/isisd.conf"

# Watchquagga configuration (please check timer values before using):
WATCH_OPTS=""
WATCH_DAEMONS="zebra bgpd ospfd ospf6d ripd ripngd"
# To enable restarts, uncomment this line (but first be sure to edit
# the WATCH_DAEMONS line to reflect the daemons you are actually using):
#WATCH_OPTS="-Az -b_ -r/sbin/service_%s_restart -s/sbin/service_%s_start -k/sbin/service_%s_stop"


pada baris ZEBRA_OPTS rubah menjadi

ZEBRA_OPTS="-A 127.0.0.1 --nl-bufsize 200000 -f ${QCONFDIR}/zebra.conf"


aslinya

ZEBRA_OPTS="-A 127.0.0.1 -f ${QCONFDIR}/zebra.conf"

setelah /etc/sysconfig/quagga diedit lalu restart service zebra dan bgpd

sumber:
http://lists.quagga.net/pipermail/quagga-users/2005-May/004524.html

Jumat, 20 Maret 2009

Solve Problem with nf_conntrack: table full, dropping packet

When i have the problem with "nf_conntrack: table full, dropping packet"
the problem was solved after i read this article from:


http://paulroberts69.spaces.live.com/blog/cns!665BC38F152E1206!1645.entry

nf_conntrack: table full, dropping packet.

If you see this message "nf_conntrack: table full, dropping packet" in your syslog on a Linux box, it's likely that it's having comms problems. I saw this recently on a DNS server that looked like it was being attacked. The problem is that when this happens, normal DNS resolution is interrupted.

I haven't found a decent solution yet, but it seems that if the system has lots of RAM then you can increase the nf_conntrack_max kernel parameter (my system is running iptables, which I assume the "netfilter" module has something to do with).

On a 2.6 kernel, you can go to /proc/sys/net/netfilter and check some of the values. For instance, nf_conntrack_count shows you the current value while nf_conntrack_max is the maximum value that is set.

You can just cat these values or use sysctl to view them:

# sysctl net.netfilter.nf_conntrack_max
net.netfilter.nf_conntrack_max = 65536

# sysctl net.netfilter.nf_conntrack_count
net.netfilter.nf_conntrack_count = 45033

To change the value, use the -w switch (in this example I've doubled the value):

# sysctl -w net.netfilter.nf_conntrack_max=131072

I think that in order to make this permanent across reboots, you'll need to add this line to the bottom of /etc/sysctl.conf:

net.netfilter.nf_conntrack_max=131072


another reference
TCP Tuning Guide:

http://fasterdata.es.net/TCP-tuning/linux.html

Minggu, 01 Maret 2009

Fail Over Layer 2 tanpa STP menggunakan script dan bridge

Seringkali kita membutuhkan link yang bisa fail-over di layer 2 tetapi tidak memungkinkan menggunakan STP maka cara demikian bisa menjadi pilihan.

Skenario



|-[Link-1]-|eth1 comment "backhaul"|
[Internet]-[R1 1.1.1.1/30]-| [R2 1.1.1.2 Distribusi ]->[To User]
|-[Link-2]-|eth2 comment "backup" |


Keterangan:
----------
1. R2 Distribusi memiliki minimal dua interface untuk link ke R1, misal eth1 diberi comment="backhaul" dan eth2 diberi comment="backup", lalu eth1 dan eth2 tsb di jadikan satu bridge misal dengan nama bridge1
2. IP point to point R2 ke R1 di pasang di interface bridge1

Contoh Scipt check_backhaul dan schedulernya bisa diimport dari script dibawah ini

Script:
------

# mar/01/2009 17:27:17 by RouterOS 3.13
# software id = 9CS2-87N
#
/system script
add name=check_backhaul policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="/interface\
disable [/interface find comment=\"backup\"]\r\
\n/interface enable [/interface find comment=\"backhaul\"]\r\
\n:log info \"Waiting 15s Backhaul Forward Packet\";\r\
\n:delay 15s;\r\
\n:if ( [/ping 1.1.1.1 count=1]=1) do={\r\
\n:log info \"Backhaul Up\"\r\
\n} else={\r\
\n:log info \"Backhaul Down\";\r\
\n\
\n/interface disable [/interface find comment=\"backhaul\"]\r\
\n/interface enable [/interface find comment=\"backup\"]\r\
\n:delay 15s;\r\
\n\
\n/tool e-mail send to=\"support@domain.anda\" subject=([/system ide\
ntity get name] . \" Microwave Down \" . [/system clock get date]) body=\"\
Backup with Mikrotik!\";\
\n\
\n\
\n\
\n\
\n\
\n\
\n\
\n\r\
\n}"


# mar/01/2009 17:30:30 by RouterOS 3.13
# software id = 9CS2-87N
#
/system scheduler
add comment="" disabled=no interval=5m name=sched_check_backhaul on-event=\
check_backhaul start-date=jan/01/1970 start-time=00:00:00


Keterangan:
----------
Setiap 5 menit sekali script check_backhaul dijalankan dengan mengenable interface dengan comment "backhaul" lalu melakukan ping ke 1.1.1.1 jika rto maka interface dengan comment "backhaul" akan di disable lalu meng-enable interface dengan comment "backup"

Disable Redirect Proxy Jika Proxy RTO

Jika suatu saat proxy server down maka redirect ke proxy harus didisable
berikut adalah contoh script agar per 5 menit sekali mikrotik melakukan ping ke proxy (dalam contoh ini proxy server menggunakan ip = 1.2.3.4) jika ip 1.2.3.4 tidak bisa diping maka script "check_proxy" akan mendisable semua redirect ke ip 1.2.3.4



# mar/01/2009 17:27:17 by RouterOS 3.13
# software id = 9CS2-87N
#
/system script
add name=check_proxy policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source=":if ( [/pi\
ng 1.2.3.4 count=1]=1) do={\r\
\n:log info \"Proxy Up\";\r\
\n:foreach i in=[/ip firewall nat find action=\"dst-nat\" to-addresses=\"1\
.2.3.4\"] do={/ip firewall nat set \$i disable=no};\r\
\n} else={\r\
\n:log info \"Proxy Down\";\r\
\n:foreach i in=[/ip firewall nat find action=\"dst-nat\" to-addresses=\"1\
.2.3.4\"] do={/ip firewall nat set \$i disable=yes};\r\
\n/tool e-mail send to=\"support@domain.anda\" subject=([/system ide\
ntity get name] . \" Proxy Down \" . [/system clock get date]) body=\"Prox\
y Redirect Disable\";\
\n\
\n\
\n\
\n\
\n\
\n\
\n\
\n\r\
\n}"

# mar/01/2009 17:30:30 by RouterOS 3.13
# software id = 9CS2-87N
#
/system scheduler
add comment="" disabled=no interval=5m name=sched_check_proxy on-event=\
check_proxy start-date=jan/01/1970 start-time=00:00:00