PT. Hawk Teknologi Solusi

Silahkan Cari Disini

Rabu, 10 September 2008

Solusi Cara Membatasi IP Tujuan dan MAC Client yang diizinkan

Kasus:
Sebuah perusahaan ingin agar karyawannya hanya bisa browsing ke IP tertentu saja dan hanya dari Komputer dengan MAC tertentu saja yang boleh ke Internet.

Caranya:
Buat address-list misal dengan nama = "web-allow" , contoh scritpnya:

/ip firewall address-list
add list=web-allow address=203.89.24.34 comment="Datautama" disable=no
add list=web-allow address=202.152.54.73 comment="" disable=no
add list=web-allow address=202.152.54.74 comment="" disable=no
add list=web-allow address=202.155.43.103 comment="" disable=no
dst..

atau dengan winbox sbb:



Lalu buat filter rule chain forward dengan script misal sbb:

/ip firewall filter
add action=add-src-to-address-list address-list=mac-allow \
address-list-timeout=1m chain=forward comment=\
"add PC allow mac to address-list mac-allow" disabled=no src-mac-address=\
00:1B:24:A5:A3:64
add action=add-src-to-address-list address-list=mac-allow \
address-list-timeout=1m chain=forward comment="" disabled=no \
src-mac-address=00:08:0D:A7:45:CC

dst...

atau melalui winbox caranya sbb:






dengan demikian jika ada traffic data dari komputer dengan MAC yang tertera di atas maka ipnya akan di masukkan dalam address-list = mac-allow selama 1 menit, jika dalam 1 menit tidak ada traffic data maka address-list ip dari mac tersebut akan hilang karena ini sifatnya dinamis



Berikutnya di bagian NAT
buat seperti contoh gambar winbox dibawah ini:


di tab Advanced pilih Src Address-list dengan = mac-allow
dan Dst Address-list dengan = web-allow


dan di tab Action pilih = masquerade


dengan demikian hanya ip dari mac yang diizinkan dan ip tujuan yang tertera dalam web-allow yang dapat diakses oleh pengguna di jaringan tersebut

2 komentar:

Dinesh mengatakan...

Thanx a lot for all the tips...

Anonim mengatakan...

Sangat menginspirasi Pak

Bagaimana dengan RT/RW net , sy bedakan blok ip setiap kliennya.

yg saya alami dengan 1 klien diantaranya adalah kantor kecil yg pengen setting seperti ini , apakah kantor tsb pasang router sendiri atau bisa di blok dr router RT/RW kita

thanks before
Agus